Forums » Ask a Question

Use this forum to post your questions to our experts – you need to be logged on to do it (you can register here ), then scroll down to the bottom of this page and click the blue Post Thread words

If you can help answer the question, feel free to post a reply – you need to be logged on to do it (you can register here ), then hit the reply button on the thread.

 

To go back to the experts page click here>>

AuthorMessage
Fredtselk
Fredtselk

Posted: Sun Mar 13, 2011 2:44pm

Post Subject: Webasto Problems

Hi Folks, I have a Webasto TopE heater which refuses to start properly. It will go through the initial startup sequence, produce lots of white smoke with the smell of unburnt diesel, then shuts down. I have been unsuccessful it getting an Engineer to come and look at the unit. Is there something I could do myself to help rectify the problem? Fred

Tony-B
Tony-B

Posted: Sun Mar 13, 2011 3:41pm

Post Subject: Webasto Problems

As soon as I see questions like this about any of the big three heaters I have this urge to answer - Yes, fit a solid fuel stove - but that is not helpful even if it is what many have done. The best I can do is to point you to a rather good illustrated set of servicing instructions http://www.canalworld.net/forums/index.php?showt opic=20695. Before you try that I would advise that you make sure the filter in the supply line is clean, the batteries are well charged (or the engine is running at fast idle or above)and the supply cable and glow plug cable are of sufficient size. Tony Brooks

Most Read

Newsletter Sign Up

Canal Boat monthly newsletter
Sign up to receive our regular email newsletter

Our Privacy Policy

Like us on Facebook



Follow us on Twitter

Cache: Disabled for this object  Total Queries: 43.  Total Objects: 162.  Total Unserialized: 3. Total Runtime: 0.64 seconds.