Forums » Ask a Question

Use this forum to post your questions to our experts – you need to be logged on to do it (you can register here ), then scroll down to the bottom of this page and click the blue Post Thread words

If you can help answer the question, feel free to post a reply – you need to be logged on to do it (you can register here ), then hit the reply button on the thread.

 

To go back to the experts page click here>>

AuthorMessage
Robert
Robert

Posted: Sun Aug 30, 2015 3:34pm

Post Subject: Thetford c200

I have recently found my red led warning light on the Thetford was not working. I took it off and tested it did not work. So bought a Thetford replacement led. No indication of + or - tested. Replaced the + to the white lead for the old led and - to the black lead. The led is now on all the time. I have tested with a meter and there is always a 12 voltage going to the led. Any ideas why this should be and what I can do to correct the problem.

Tony-B
Tony-B

Posted: Sun Aug 30, 2015 3:56pm

Post Subject: Thetford c200

I am out boating at the moment and only have a partial mobile broadband connection. I need to access the C200 manual and parts lists to see what you are talking about but Thetford seem to have all their manuals on Dropbox. At the moment Dropbox is returning errors so I can not get the information I need. When I get home next week I will try on a proper broadband connection. An straight forward LED only works when connected the correct way round and at its rated voltage you can not harm it by reverse connection. This may not be true for modern types with additional electronics encapsulated with in it. If the LED is the "tank full" indicator I would suspect the switch in the waste tank is jambed in the full position but need to see the manuals to be sure.

Robert
Robert

Posted: Mon Aug 31, 2015 11:22am

Post Subject: Thetford c200

Thanks Tony, The C200 is a cassette toilet and the led is on whether the cassette is in the toilet, full or empty or is out of the unit. I am stuck on the Rufford arm stoppage for a few weeks more and can not access pdf files or help and can not find out where the switch is for the led if that is the problem.

Tony-B
Tony-B

Posted: Mon Aug 31, 2015 6:04pm

Post Subject: Thetford c200

I have managed to download the various publications and none are very helpful. The parts list shows a reed switch in a position on the diagram that is close to the water supply tube and vacuum breaker in the base unit. I suspect this has either failed or is being influenced by a magnet. Although nothing is shown I suspect there may be a floating magnet in the waste tank that closes the reed switch (by magnetic field) when the tank is full. The magnet would need to be restrained in some way so it may well be clagged up with toilet paper or some such. I think it may be best to talk to Thetford direct or a dealer. The nearest to Rufford is: Red Lion Caravans, 2.4 miles,Scarisbrook bridge Ormskirk, Lancashire L40 8HQ England. T +44 1704 840032

Robert
Robert

Posted: Wed Sep 02, 2015 10:25pm

Post Subject: Thetford c200

Thanks again Tony, just managed to get internet back. Will follow your suggestions and get back if I find out the problem. Robert

Robert
Robert

Posted: Fri Sep 04, 2015 6:00pm

Post Subject: Thetford c200

Thanks for the advice, swapped the reed relay and tested with empty tank and it works. Robert

Most Read

Newsletter Sign Up

Canal Boat monthly newsletter
Sign up to receive our regular email newsletter

Our Privacy Policy

Like us on Facebook



Follow us on Twitter

Cache: Disabled for this object  Total Queries: 43.  Total Objects: 162.  Total Unserialized: 3. Total Runtime: 1.01 seconds.